Performance degraded

Incident Report for Addgene

Resolved

This incident has been resolved.
Posted Mar 01, 2024 - 16:39 EST

Monitoring

We have identified the issue and were able to resolve it. We will continue to watch the issue to make sure it doesn't occur again.

Apologies for the disruption.
Posted Mar 01, 2024 - 16:26 EST

Investigating

We are currently investigating this issue.
Posted Mar 01, 2024 - 16:18 EST
This incident affected: www.addgene.org (www.addgene.org).