Services not available

Incident Report for Addgene

Resolved

This incident has been resolved.
Posted Jan 09, 2024 - 15:13 EST

Investigating

We are experiencing failures that are causing our websites to be unavailable for at least some users.

We are actively investigating and will have additional updates shortly.
Posted Jan 09, 2024 - 15:12 EST
This incident affected: www.addgene.org (www.addgene.org, Search).