Increased errors
Incident Report for Addgene
Resolved
This incident has been resolved.
Posted Nov 27, 2023 - 15:17 EST
Update
Service is restored. We apologize for the disruption.
Posted Nov 27, 2023 - 15:16 EST
Investigating
We are aware of errors causing our site to not load. We are looking into it!
Posted Nov 27, 2023 - 15:12 EST
This incident affected: www.addgene.org (www.addgene.org, Search).