While the AWS issue is still open, the ways we use AWS have sufficiently improved enough so that we can call this resolved for Addgene.
Of course, we will continue to monitor and keep you all up to date if anything changes.
Thank you!
Posted Oct 20, 2025 - 16:19 EDT
Update
AWS is indicating the resolution might be near at hand and indeed our error rate is starting to subside.
Thank you for your patience. The end is in sight.
Posted Oct 20, 2025 - 14:02 EDT
Update
The AWS issues continue. They are making progress, but we are still seeing assorted failures. One notable example is downloading our ebooks. This is very unreliable right now. We appreciate your patience as we work towards resolving this incident.
Thank you,
Posted Oct 20, 2025 - 12:08 EDT
Monitoring
Like many websites, we are being affected by a significant issue at the Amazon Web Services (AWS). This is a vendor we directly use.
Overall, our site is up and available, but some functions are slow or effectively not processing. This includes things like emails being delayed, sequences potentially not generating for display in a timely basis, and more.
We are implementing compensating controls where ever feasible and closely monitoring AWS updates.