Services not available
Incident Report for Addgene
Resolved
This incident has been resolved.
Posted Nov 11, 2023 - 15:56 EST
Investigating
We are experiencing failures that are causing our websites to be unavailable for at least some users.

We are actively investigating and will have additional updates shortly.
Posted Nov 11, 2023 - 15:53 EST
This incident affected: www.addgene.org (www.addgene.org, Search).